Это просто правило брандмауэра, которое заставит всех ваших пользователей за Mikrotik использовать DNS-сервер, который мы сами определяем.

Переходим в IP - Firewall - Nat либо пишем в консоли: 

/ip firewall nat

Добавляем пару правил редиректа:

 

add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=tcp dst-port=53
add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=udp dst-port=53 

Которое заставит всех пользователей с настраиваемым DNS-сервером использовать 192.168.88.1 в качестве своего DNS-сервера, это правило будет просто перенаправлять весь запрос, отправленный на ANY-IP: от 53 до 192.168.88.1:53

 

Разные DNS для пользователей.

 

/ip firewall nat
add chain=dstnat protocol=udp dst-port=53 src-address-list=LIST1 action=dst-nat to-addresses=IP_DNS1
add chain=dstnat protocol=tcp dst-port=53 src-address-list=LIST1 action=dst-nat to-addresses=IP_DNS1
.....
add chain=dstnat protocol=udp dst-port=53 src-address-list=LIST-N action=dst-nat to-addresses=IP_DNS-N
add chain=dstnat protocol=tcp dst-port=53 src-address-list=LIST-N action=dst-nat to-addresses=IP_DNS-N